We are currently experiencing a service disruption in our Admin Portal UI
Incident Report for Red Hat 3scale
Postmortem

Summary:

On October 30th of 2019 a high volume of specifically targeted requests were made, leading to a Denial of Service on the 3scale Developer Portal UI and Admin Portal UI. API traffic was not affected during the incident.

Timeline:

  • 30/10/2019 11:42 UTC Developer Portal UI and Admin Portal UI are down
  • 30/10/2019 12:16 UTC Developer Portal UI and Admin Portal UI are up
  • 30/10/2019 12:35 UTC Developer Portal UI and Admin Portal UI are down
  • 30/10/2019 12:54 UTC Developer Portal UI and Admin Portal UI are up

Root cause:

A high volume of requests was made by an external agent, causing some expensive database queries that led to a denial of service of the 3scale Developer Portal UI and Admin Portal UI.

Preventive Actions:

  • Limit exposure of the affected queries
  • Enhance queries so they have a lower CPU impact on the database
Posted Oct 31, 2019 - 14:51 CET

Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 13:54 CET
Investigating
Our operations team is working to identify the root cause and implement a solution.
Posted Oct 30, 2019 - 12:42 CET
This incident affected: Admin Portal UI.